0
Planned
burrum 5 years ago • updated by Alex Jenter 7 months ago 13

Reproduce:

1. Enable formatting

2. Make some bullet items

3. Select bullet list and do Formatting > Clear context command


Result: bullets are not removed.


Even more:

4. Save that note

5. Disable formatting

6. Open, edit, save note


Result: bullets still not removed.


And:

7. Open that note with disabled formatting

8. Press enter at the end of the bulleted line


Result: new bullet line is added


We can spawn bullets with disabled formatting!

text-formatting

Not sure if i want bullets removed, when i remove other formatting. How about selecting all lines with the bullets and press Ctrl+L to remove them? Even better Ctrl+Shift+L as a new key, that removes a bullet in general.

Probably related: when pasting plaintext (from notepad) numbered list


1. Abc<br>2. Cde<br>3. Fgh


into CN with disabled fromatting, it becomes formatted "Numbered List" with no option to make it plaintext (2.0.1).

Possibly related: Ctrl+TAB does not insert TAB character, but instead formats text as indented. Cannot select this indent because it's not TAB char but formatted indent. If copy-paste text indented like this into regular notepad, indent turns into 3 spaces.


Conditions: Options > Editor > Auto-Indent off, Options > Editor > Text formatting off


Alex, if this is different I'll create a separate bug.

Yes, this is different and actually should be already fixed in 2.0.3 Beta 1 - please check.


Confirmed. Couldn't reproduce in 2.0.2, looks it was fixed in that release.

Whether the bullets should be removed is a good question. I'd like someone else to speak their mind?


Or maybe a third option - replace bullets-as-formatting with bullets-as-unicode-symbol?

Quote: Whether the bullets should be removed is a good question.

The answer is No. Sometimes i need to remove formatting like underline, italic, etc. I definitely want to keep my bullet list! As posted a month ago, i can select all relevant lines and press Ctrl+L twice to remove the bullets, if i really like to.

This is my reasoning: anything I cannot edit as a text character is formatting. It cannot be rendered when formatting is disabled and I expect it to vanish when I clear formatting.


Putting a character is a possible option, but questions appear:


* Is it an asterisk
- or a minus?
 * precede char-bullets by space
 * (accepted in some groups)?
* or not?

Removing the bullets destroys the structure of the text and makes the clear command meaningless to me. Even if it is an extra step i strongly recommend to remove bullets separately. As for converting bullets to plain text, e.g. with an asterisk, i suggest to add it as a request on its own. The feature could then be used to convert asterisk alike formatting to bullets and vice versa.


Testing 2.0.3-beta1: 4-6 almost fixed. One problem left:

1. Enable formatting, new note, make couple bullets, save

2. Disable formatting

3. Open the note: bullets are cleared on open (correct)

4. Save note without modification

Result: bullets are saved and rendered in the notes list. To see that they are really saved, enable formatting again and open the note. I think this is because note with formatting is not marked dirty when it is opened with formatting disabled.


7-8 does not reproduce anymore.

Is this issue still actual?