+7
Planned
Alex Jenter 6 years ago • updated by Arseniy (CN Support Team) 4 years ago 8

Hi~
I have a font rendering bugs in 'edit window'. Personally, I usually use Chinese and Korean. But as you can see from the screenshot, even if I customized the 'Text font', it appears really weird. When characters comes to a different language, it just changed to a different font for the that language.

Image
http://www.freeimagehosting.net/uploads/a62ceb5f9a.png

my environment:
win7.en (locale language is chs)
cinta ver 1.4.3


(http://cintanotes.com/forum/viewtopic.php?f=6&t=1115)


I think it has nothing to do with the character encodings. The same problem occurs  when just using ascii characters.
Could you please describe the steps needed to repeat the problem on the screenshot in more detail?
When I open and add some text the fonts are fine.
Are you sure that the "Previously saved text" is not formatted as "Monospace"? Please try selecting it and pressing Ctrl+M several times.

Yes, these are steps to represent the problem:
1. change note editor font to a non-monospaced font--for example, 'Microsoft Yahei'(微软雅黑);
2. create a new note, add some text then close it;
3. reopen the note, you can see the font of the previously saved text is not the specified non-monospaced font;
4. type some new text, you can see the font of the new text is the specified font.



The 'text font' setting at position 1 applies correctly in the note list(position 2) but not in the editor(position 3). Is it a bug?
Probably this is a bug, I'll investigate it further. Thanks!
I can't get my hands on "Microsoft Yahei".. Can you repeat the bug with a more common, international font, like Verdana or Tahoma? If not, could you please send me the TTF file? Thanks!