0
Under review
ChrisCN 3 years ago • updated by Alex Jenter 2 years ago 8
I just printed two notes - one containing text with highlighted parts.
I printed on a color printer BUT the highlighted text got printed italic!?
Hi Chris, printing is redirected via creating a temporary HTML file. It is located in your %TEMP% directory and its name is cintanotes-print.temp.html. I checked the file's content as well as it's presentation in Chrome. The text gets highlighted correctly. I then printed it using a PDF printer which created italic style instead. I did not test real printing though. Nevertheless, from what i see, the problem is related to the browser or the printer device.
Thomas, thanks for having a look at it. 

I did too and found the text embedded within the tag <em>YYY</em>
and this is defined as >> em {background:#fffaa0; font-style:inherit;}

I am not good at stylesheets and can't verify if there is a bug or at least a compatibility problem with a browser. Opening the temp print file in Firefox or Chrome renders the highlighted text correctly!?

Hmm, any idea which component (browser, printer,...) is the cause of the problem or what can be done to fix it?

Chris, i've just asked google ;) The web is full with posts regarding this problem. Not only Chrome, but Firefox is also affected. For Chrome there is an easy workaround by adding "-webkit-print-color-adjust: exact;" to the CSS definition of the body. I did not check for Firefox or IE, as there seems to be no general or even easy solution to this. This is rather hard for Alex to fix. Thomas
PS: For Chrome there is an extension which supports printing of Background Colors. Search for "Print Background Colors"
Under review
Hi Chris, sorry for the late reply. Did Thomas's suggestions help with the problem?
Sorry for the late reply as well.

It's nice to know about the Chrome solution - but in the my main environment the standard browser is IE. So the problem still persists.

But I must admit that this is a minor problem and I can live with the strange behavior.

If you can easily build a workaround - I will welcome it.
If it is hard to fix in CN - you can ignore the problem (at least for me).

Thanks for having a look at it.
Chris
Chris, for IE there seems to be a workaround: try turning on Print Background Colors and Images under options on the print preview.
Chris,

maybe this will help? Print Background Colors

Thomas